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Basic Guidelines for Website Accessibility 

 

The basic idea of accessibility is providing an alternative way of browsing or performing an action on 

a website. 

A person with visual impairments is assisted by a screen reader, the most popular of which is NVDA 

software. This program reads him aloud what is occurring on the screen. It passes through the site 

code and with the tags indicates the meaning of each element on the site. 

In order for the software to be synchronized with the site, the site must be built in a consistent 

hierarchy according to accessibility standards. 

With the help of the document reader: text files are converted to an audio file, audio files are 

converted into text or video and then translated into sign language. 

 

Types of disabilities: 
Cognitive, Visual, Motor, Hearing, Speech, Mental Health. 

 

Website accessibility from all aspects 

• Website code 

• Website design 

• Website content - it is the responsibility of the webmaster to upload accessible content to the 

website 

Accessibility of information 
1. Handling new content pages 

2. Handling different types of files 

 

Handling new content pages 

• It is recommended to work with existing templates that are accessible. 

• In the event of adding new templates and / or modifying existing templates and / or new 

components and / or scripts, which may interfere with the accessibility of the site and / or are 

inaccessible at all, it is recommended to send an email to the Support center of EqualWeb in 

to perform a test and receive a proposal for future accessibility services for these pages to 

support@equalweb.com. 

 

  

mailto:support@equalweb.com
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Web page structure: 

• The page has to be built in a hierarchy of titles (H1 to H6) 

• Each page needs to have an H1 title, but not more than one. 

• Titles from H2 to H6 can be used indefinitely, depending on the hierarchical structure. 

• Each page needs to include a unique title (TITLE). 

• Each page must have a page language (LANG). 

Use of lists: 
UL / OL tags should be used with LI to display lists (bullets / numerical list) 

 

Use of tables: 

• Tabular content should be displayed in tables, including the use of a table header (TH). 

• Avoid using tables for design purposes in the site (use DIV or any other semantic tag). 

Alternatively, use text / lists. 

Use of images: 

• Each image used as lifestyle / decorative images must be given a text description (ALT) of up 

to 120 characters, including spaces. 

• Banners that are built as background images (BACKGROUND IMAGE) and do not contain text 

do not require a description (ALT). In the case of a banner containing a picture + "live" text: 

separate the image from the content and provide a text description (ALT) to the image.  

• An image banner where the text is part of the image is not accessible! 

 

Pasting text to website: 

• It is advisable to enter text with no design to the web page. 

• Avoid large text blocks. 

• Use verbal content in simple language. 

 

Links: 

• The essence of the link: Provide a clear description to the user of where the link leads ("To 

register for the summer-camp click here" - instead of "Click here").  

• Links containing an image: Provide a text description to the image (ALT), or give live text to be 

displayed next to the image. 
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Making PDF/Word files accessible 

 

Objectives: 

• Support of screen readers and screen magnifiers 

• Reading aloud by converting text to speech 

• Keyboard operation 

• Set navigation preferences such as automatic scrolling 

• Set accessibility preferences in the Wizard, which is mostly compatible with magnification 

software and screen readers 

 

What needs to be done when editing a Word file 

• Determine the document’s reading order 

• Pagination of the document by specifying headers, fields, tables 

• Set up alternate text for links, images 

• Create navigation aids in the document: headers, bookmarks, table of contents 

• Set the language of the document 

• Choose the font 

• Use fixed design styles 

• Alignment to the left 

• Colors 

• Alternate text 

• It is best not to use language abbreviations: for example, sch. for school, but in full writing, as 

the reading program usually does not read the full expression. 

• Do not use the following fonts: TIME NEW ROMANS and DAVID (curly fonts). Use rounded 

fonts such as ARIAL, TAHOMA, and HELVETICA. 

 

Workflow for creating an accessible PDF file 
Creating an accessible document in Word and saving it as a PDF file 
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Rules for creating an accessible Word/PDF file 

Titles 
To allow keyboard navigation, the document should be divided into sections: main title, subheading, 

and content. With keyboard navigation the user can skip between titles, select the title he is 

interested in reading, and reading the selected section. 

A document that is not structured in an ordered hierarchy - the reading of the document is 

continuous and forces the user to read the whole document without being able to skip or select the 

section that interests him. 

How to build a heading ? 
Under Home > Style ruler: 

For the main title we will choose: Heading 1 

For Sub-heading: Heading 2 

 

 

In order to design the title 

Right click the selected title>Modify> Modify style: Choose font, font size, writing direction, color and 

more… 

• Heading 1 (Main title) – Will be larger and more emphasized than a Heading 2. 

• Keep the spacing between the title and the text and between one section to another. 

• Choosing font and direction of writing, bullets, and paragraphs. 

• Choosing a font - As a first step, it is advisable to use clear and readable fonts. 

• Selecting the document direction (Hebrew / English) - The document language should be set 

at the beginning of the job. 

 

Recommendation: Build your own predefined design styles for: Header 1, Heading 2, Heading 3, Text 

Content and more… 
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Alternate text for image 
Right click the image > select format picture > select tab: Alt Text > Enter image description. It is 

advisable to describe the image accurately. 
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Alternate text for links 
Highlight the text you want to create the link for > right click to select Hyperlink > in the ScreenTIP 

enter the link title > in the address write the domain address as in the following example. 

Make sure to use an accurate description / explanation describing the link (the reader reads the line 

of text: "for download and reading click here" so there is no point in reusing it) the description should 

be different than the link row itself. 

 

Screenshot from Word commands for inserting alternative texts to a link.
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Creating an e-mail link 
To create an e-mail link, highlight the text> right key Select Hyperlink> Select E-mail Address> Fill in 

the screen description (different description from the mailbox and the row) 

Fill in the e-mail field 

 

Using bulleted lists 
1. Place the cursor somewhere in the document. Select the 

Home tab. 

2. In the Paragraph group, select the Bullets button. 

3. Type each bulleted item in the bulleted list. 
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Using ordered lists 
1. Place the cursor somewhere in the document. 

2. Select the Home tab. 

3. In the Paragraph group, select the Numbering button. 

4. Type the continuous steps. 

 

 

 

 

 

 

 

 

 

 

Adding alternate text to charts / shapes 
5. Right click on Chart/shape. 

6. Select Format Shape. 

7. Select Alt text. 

8. Type a description and a title. 
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Using tables in the page 
Adding alternate text to tables 

9. Right click on the table. 

10. Select Table properties. 

11. Select the tab Alt text. 

12. Type a description and a title for the table. 

 

 

 

 

 

 

 

 

Setting a row in a table 
Make sure that the tables do not contain empty rows, 

splatted cells, blended cells, or empty lines, empty columns 

– the screen reader loses the count in such cells. 

Empty columns - The screen reader loses the count in 

these cells. 

In order for the screen reader to read the table in a correct 

way, i.e., reading the header before each line, mark a V as 

a title bar at the top of each page. 

 

 

 

 

 

 

 

 

  



 

 

 

  

12 

Saving a Word file as PDF 
File> Save as> Save as type> Select PDF> click Options> Mark V in columns: Document structure for 

accessibility tags, and in long documents it is also recommended marking "Create bookmarks" using 

titles. 
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Accessibility checks in Word / PDF document 
The first recommended option is to run a document reader to perform a file check. 

The second option, which is simpler, is to add a Table of Contents to the document via Word. 

If the Table of Contents is properly organized according to the titles you entered, then you did a good 

job. Otherwise, correct the titles, delete the table of contents, and create a new one. 

Reference> Table of contents> Select the content design according to the suggestions in Word. 
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Accessibility for Excel documents 

 

Spreadsheets allow people with different disabilities to read the workbooks and charts. It is 

recommended to use the accessibility checker to make sure the sheets are accessible. 

The rules for accessible EXCEL documents are similar to those of the WORD documents mentioned 

above. 

In general, it is recommended to use tables with a simple structure without splitting or merging cells 

or merging lines. If it is not possible to avoid the use of simple tables, the following actions can be 

performed. 

 

Opening a sheet 
A title must be provided for each sheet that is used in the document: 

 

1. Right-click on a sheet 

2. Type the sheet name 

 

 

 

 

 

Setting a table format 

 
1. Select a cell range in the table 

2. On the Home tab > Design as Table 

3. Select a table format from table format design. 

It is advisable to choose a simple structure. 

4. Mark V in the check box "My table has titles"  

5. Click OK 

 

The range of selected cells has been defined as a 

table and can be updated at any time with the addition 

of rows or columns. 

 

 

 

 

 

 

Combined cell headers 
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If you have used multiple merged cells in the headers after defining the table format, what will 

happen is that the merged header row will split. 

One way is to define the range of cells to be merged as headers. That is, every time you create a 

suitable merged header, you need to define the column headers in the line below the merged header 

row again and then continue to enter the data in the table. 

 

 

1. Select the row of headers in the table or the range of merged cells 

2. On the Home tab > Format as Table > select Header Row 

3. Click OK 
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Adding titles to a new table 
 

1. Select the header row in the table 

2. On the Home tab > Format as Table > select Header Row 

3. Click OK 

4. Excel creates header rows with the default names: Column1 onwards. 

5. Type new names and descriptions for each column in the table. 
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Hiding empty columns 
 

In order to help keyboard users who, use or do not use, a 

screen reader, you can hide empty columns in the sheet: 

 

1. Mark the last empty column in the table. 

2. Pressing and holding the SHIFT key and pressing the END key 

3. Continue pressing the SHIFT key and then press the right or 

left arrow key depending on the reading direction. 

4. This action will mark the entire range of columns from here to 

the end of the sheet. 

5. Right-clicking on the selected area > "Hide". 

 

Unhide columns: Select the hidden columns > Right click > 

Select "Unhide". 

 

 

Hide empty rows 
In order to help keyboard users who, use or do not use, a screen 

reader, you can hide empty rows in the sheet: 

 
1. Mark the last empty row in the table. 

2. Press and hold the SHIFT key and press the END key 

3. Continue pressing the SHIFT key and then press the right or left 

arrow key depending on the reading direction. 

4. This action will mark the entire range of rows from here to the end 

of the sheet. 

5. Right-click on the selected area > "Hide". 

 
Unhide columns: Select the hidden rows > Right click > Select "Unhide". 
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Alternative text 
 

When using images, SmartArt graphics, shapes, groups, 

charts, embedded objects, video, and videos—alternative 

text must be included for each item displayed to describe 

it for people with disabilities. The replacement text should 

be as accurate and detailed as possible to what is shown 

in the image. 

 

1. Right click on the image or object. 

2. Select Edit Alt Text 

3. An Alt Text panel will open on the left side of the screen. 

4. Type one sentence or at most two (about 120 characters) to 

describe the image and its relationship to the content. 

 

 

 

 

 

 

 

Alt text for shapes or SmartArt  
 

1. Right click on the shapes or SmartArt. 

2. Select Edit Alt Text 

3. An Alt Text panel will open on the left side of the screen. 

4. Type one sentence or two (about 120 characters) to describe 

the shapes or SmartArt and its relationship to the content. 
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A decorative visual item 
 

In the event that the decorative element we have used does 

not add informative interest to the content, the element can 

be marked as decorative. In this case, when using a screen 

reader, the screen reader will skip over these elements and fill 

in important information for screen reader users. 

 

1. Right click on the shape or object. 

2. Select Edit Alt Text 

3. An Alt Text panel will open on the left side of the 

screen. 

4. Mark V in the "mark as decorative" button. 

 

 

 

 

Using accessible text color 
 

It is recommended to make sure that the color is not the only 

way by which the information on the page is conveyed. 

Individuals who are blind, visually impaired, or color blind, may 

miss the significance of the colors that convey special 

messages.  It is advisable to use sharp colors that differentiate 

the text and the background.  

To find color contrast you can use the accessibility tester.   

The standard requires a contrast ratio of 1/4.5 between the 

color of the text and the color of the background.  

 

There are programs that can be found on Google as in the following link: 

Color Contrast Analyzer - CCA 

 

 

 

 

 

 

https://www.tpgi.com/color-contrast-checker/
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Summary: 

 
• Navigation using the TAB key in Excel tables will be possible in the table range only between 

non-merged cells. 

• When a table includes merged cells, screen reader users should navigate with the arrow keys. 

Using the down arrow will allow users to get to the next row that does not include merged 

cells and from there the navigation will continue using the TAB key. 

• If only some of the cells in a row have been merged, a user recognizes that navigation using 

the TAB key has deviated and must realize that he must go back in the navigation. 

• It is important to maintain the other design rules: using colors with a contrast ratio between 

the text and the background color of 1:4.5, providing alternative text for images, objects and 

links, using a legible font, defining the document's language, writing direction, headings and 

all other accessibility rules similar to WORD or PDF documents. 

 

  



 

 

 

  

21 

Accessibility when using e-mail 

Accessibility in a new email message and/or reply 
OUTLOOK users are advised to use the accessibility checker before sending or replying to an e-mail 

message, 

Run the accessibility checker to make sure people with disabilities can easily read and edit the 

content:  

 

1. When sending a new email or replying to an email in the ribbon > select the Review tab. 

2. Select Check Accessibility 

3. View the results in a list of errors and warnings and recommendations for correction. 

Adjust test results accordingly 

 

 

Recommendations for correction of e-mail messages before 

sending
 

 

To address accessibility-related errors and warnings, select the issue from the 

list > open the recommended actions with the arrow and apply them. 
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Time Based Media Accessibility 

 

The AA-level standard guidelines require that time-dependent media include accessibility 

adjustments for people with hearing impairment or deafness and for people with visual impairment 

or blindness: 

For people with hearing impairment or deafness - transcription is required for sound / audio files 

For people with hearing impairment or deafness - subtitles with expanded captions that describe 

vocal occurrences 

For people with visual impairment or blindness - a voice description in a separate sound track 

embedded in the movie that includes an audio description of visual occurrences unaccompanied by 

text 

 

For accessibility of videos, follow these steps: 
1. Provide alternatives to the voice channel - subtitles for narration and speech, written 

descriptions of the significant sounds for understanding the movie. 

2. Provide alternatives to the visual channel - audio descriptions for meaningful visual 

information. 

3. Synchronize alternatives - ensure that the alternatives appear simultaneously with the 

original information. 

4. Last thing that must not been forgotten - make sure that the video player you use is 

accessible to keyboard users with or without a screen reader in a way that allows you to reach 

all the buttons using a keyboard and add labels to the action buttons. 

 

Voice description and extended captions 
A voice description provides people with visual impairment, blindness, or people with other 

disabilities who need assistance in understanding nonverbal visual events. There are two main ways 

to add a voice description to videos. The first is to add expanded captions to videos so that people 

whose sight is normal will be able to read the subtitles and screen reader software will be able to 

read using voice prompts on supported computers and peripherals. The second way is to add a voice 

description by means of narration (a human voice) that describes the visual events. Expanded 

subtitles have an advantage for people with hearing impairment while the vocal description has 

advantages for people with visual impairments. 
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Adding subtitles to YouTube videos 
Google allows to add transcription and captions to YouTube videos at no charge. Users can choose 

whether to display or hide subtitles. 

 

Adding subtitles to a video using YouTube 
To add transcription and subtitles to YouTube videos, you need to be connected to your Google 

account and the movies must be in your personal account. 

5. Connect to your account 

6. Select My Channel 

7. Upload the video 

8. Select “CREATOR STUDIO”  

9. Select Edit to video 

10. Select subtitles tab 

11.  Select the language for the subtitles 

12. Upload file or create new subtitles or CC 
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CREATOR STUDIO 

 

 

CHOOSING A LANGUAGE 
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CLICK ON SELECT NEW SUBTITLES 

 

 

Select the location of the subtitles in the movie in the time bar below the movie, type the subtitles 

and click + to add the subtitles. Continue like this throughout the movie. 
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You can also edit the subtitles in the time bar under the video, each subtitle you inserted appearing 

on the time bar. You can edit, change, delete, or lengthen and shorten the time the subtitle appears. 

When done, check that the subtitles are synchronized with the video, if you cannot always update. 

Alternatively, you can upload a pre-set subtitle SRT file type. 

 

SUGGESTION: 

YouTube has a detailed User manual; it is recommended to use it when necessary. 
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Facebook accessibility 

 

Regulation: 
“...(G) must make accessibility adjustments as stated in this regulation even if the hardware it uses 

for the provision of the Internet service is outside the borders of Israel; but the service is provided 

through a social networking platform (such as Facebook or Twitter), the service provider will perform 

those accessibility adjustments according to his will through the platform (such as selecting the 

contrast) ..”. 

 

Alternate text for images 
Facebook allows adding alternate text to videos and images and therefore this component is binding 

and is also anchored in the WCAG 2.2 guidelines to the AA level. 

 

Accessibility through tagging 
When you add a description to video and images before you publish them on Facebook, they will 

actually be used by people with different disabilities and allow them and their assistive technologies 

to better understand the statuses they share. 

 

Say something about the picture 
When a picture or video is added to Facebook, a text box with "Place Holder" is shown which 

disappears immediately after writing "Say something about this" (or other variations depending on 

the content). This is exactly the place to insert a brief description of the image or video. 

 

Using simple language 
It is recommended that statuses be included clearly and briefly. Statuses that contain links to other 

sites, including textual descriptions of videos and images, will be comprehensive and clarify the 

purpose in short. Using simple language is especially important when it comes to public service or 

commercial services offered to surfers through social networks. 

 

Clear text for links 
Facebook allows you write notes that you can publish on the timeline. Writing notes allows you to 

perform basic formatting functions such as highlighting text as well as adding links to selected text. 

For example, if a user wants to add to a post, he writes a number of links to a number of sites or 

services they offer - this can be done with notes.  
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Alt Text - Why is it important 
 

Alt Text simply means “alternative text” and is used online to substitute non-text content with short 

descriptive content, mostly for images (but can also substitute multimedia, videos, etc.). 

 

Most users would not encounter Alt Text, but for users with screen readers, for instance, Alt Text 

would play an essential role in their browsing experience. 

 

An image with a pup lying on the porch would trigger the screen reader that would read aloud: “A 

puppy lying on a porch. Image. Clickable. Click to visit link in new window.” 

 

Offering Alt Text for your images will not only make your website more accessible but will improve 

your SEO (search engine optimization) results as well. 

 

lt text' is it's a short-written description of an image, which makes sense of that image when it can't 

be viewed for some reason. 

 

Take a look at the photograph below, what do you see? 

 

An apt description of the image would be “A boy and a girl riding a scooter and a bicycle respectively 

in a suburban environment.” 

 

If we tried to “ask” an artificial intelligence software to describe the photo, it would probably reply 

with something along the lines of “An image with two children,” or even, “Two persons driving on the 

road.” 
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In other words, we do not yet have the technology that can accurately describe the occurrences in 

images. We must still rely on the human eye to provide Alt Text for images. 

 

How to write Alt Text 
As a rule of thumb, the Alt Text principles are: 

 

Accuracy 

 Describe the image for what it actually depicts. 

 

Bad example: “A tower.”  

 

Good example: “The top of a lighthouse against a blue sky.” 

 

Conciseness 

 Keep the description short and efficient. 

 

Bad example: “A clay, small bowl placed on a stone platter and some wrinkled fabric with 

at least 10 juicy strawberries inside.” 

 

Good example: “Strawberries in a brown bowl.” 

 

Non-redundancy 

 If an image has a body of text next to it there is no need to repeat this 

information in the Alt Text. 

 

Bad example: “Relaxed woman in black top smoking an e-cigarette as an 

alternative for real cigarettes.” 

 

Good example: “Woman in black top smoking an e-cigarette on a black background.” 

 

No-no words 

 Avoid the usage of words like “image” or “graphic” as screen readers 

already note this. 

 

Bad example: “A graphic showing a white keyboard with a green 

handicapped button.” 

 

Good example: “A keyboard with a green handicapped button.” 

 

 

When to add more detail?
 

When the main focus of your content is an image, and/or when the emotion conveyed by that image 

adds something extra to surrounding content, you can choose to describe the image with longer, 

more detailed alt text.  
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SEO 
 

Because good alt text provides semantic meaning to an image and description, it is used by search 

engines to return search results.  

Think of it in a different way: good alt text gives search engines more—and better—information to rank 

your site with, so they will rank him higher. The more thoughtful and useful you describe all your 

content to users, the easier it will be for search engine bots to understand as well. 

 

Who’s responsible for Alt Text? 
It is important to note that Alt Text for images is a standard requirement to achieve the ADA and 

WCAG 2.1 web accessibility guidelines. This requirement is stipulated in the law and is a must for all 

businesses with websites. 

 

Moreover, obliging to this requirement is the sole responsibility of the business. Even when choosing 

to work with a web accessibility vendor, such as the leading company EqualWeb, the job to jot down 

Alt Text is of the business—as images normally change and update. A web accessibility solution 

provider would needlessly fill in the Alt Text details only to later provide false descriptions of the latest 

images. 

 

A vendor could notify a business that it's missing Alt Text, and we at EqualWeb sometimes do this due 

to our impeccable service, but ultimately it is not the responsibility of the accessibility provider. 

 

Test your text
 

Read your image descriptions out loud, in the context of the rest of the page content. If it makes 

sense and adds something useful - it's good alternative text. 
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Customer Content Responsibility 

 

GENERAL GUIDELINES FOR THE CUSTOMER TO MEET REGULATORY OBLIGATIONS 

Remarks Blind Users  Deaf Users Type of media 

Make sure all 

buttons are 

accessible. 

Headings should be 

extended, i.e. a 

description of significant 

occurrences related to 

the video. 

Subtitles should be added in VTT 

format, a new HTML 5 standard 

that enables assistive 

technologies to read  with 

different voices for each 

character. 

A video created or 

hosted by the 

customer 

Make sure all 

buttons are 

accessible. 

  
A movie that is 

embedded from an 

external source 

Make sure all 

buttons are 

accessible. 

Insert subtitles in VTT 

format, a new HTML 5 

standard that enables 

assistive technologies to 

read with different voices 

for each character. 

Make sure there are captions for 

an audio file. 

Sound files – wav, 

mp3  and other 

formats 

Captioned like a 

video. 

Captioned like a video. Placement of a link that allows 

users to move to a page that 

displays the content in an 

accessible way that can be 

understood. 

Flash advertising 

Make sure all 

buttons are 

accessible. 

Headings should be 

extended, i.e. a 

description of significant 

occurrences related to 

the sound. 

Insert subtitles in VTT format, a 

new HTML 5 standard that 

enables assistive technologies to 

read with different voices for each 

character. 

Animated GIF (s) 

It is advisable to 

reduce the use of 

tables. 

Use headers, paragraph 

marks, bullets, ALT tags 

to images. 

Use headers, paragraph marks, 

bullets, ALT tags to images. 

PDF / WORD 

documents 

 
ALT tags should be 

provided with alt text for 

animation. 

ALT tags should be provided with 

alt text for animation. 

Banner files 

 

 
  

ALT tags should be 

provided with alt text. 

ALT tags should be provided with 

alt text. 

Image files : JPG, 

IMG, TIF 
 

Will not be considered 

accessible without audio. 

Will not be considered accessible 

without audio. 

Captcha 
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Editor's recommendations: 

• Many efforts have been made to make the site accessible to people with disabilities, 

please abide by the rules of accessibility as required by law. 

• Once a year it is recommended to perform an accessibility test of the site and the site's 

contents and correct the defects (otherwise the site will not meet the accessibility standards 

required by law). 

• Our services can be hired in a variety of areas: accessibility of sites, accessibility of additional 

content pages, accessibility of content / files, accessibility testing / advice. 

• An accessibility statement must be published in the site. 

 

Good luck 😊 

 

 
IT'S IMPORTANT TO THEM.  
THIS IS IMPORTANT TO YOU.  
IT'S SOCIAL. 
 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 


